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Beginning with Photoshop 21.2 (June 2020 release), Select Subject is now content-aware and applies new custom algorithms when it detects a person is in the image. When creating a selection of portrait images, treatment around the hair area has been vastly improved to create a detailed selection of hair. To temporarily turn off the content awareness, you can press and hold the Shift key while performing Select Subject.  
[image: Select Subject in Photoshop]
The Select Subject ( ) command lets you select the most prominent subject in an image in a single click. Powered by advanced machine learning technology, Select Subject is trained to identify a variety of objects in an image—people, animals, vehicles, toys, and more. 
1. Select subjects automatically 
Select Subject automatically selects the prominent subjects in your image. To access Select Subject, do one of the following:
. While editing an image, choose Select > Subject.
. While using the Object Selection, Quick Selection, or Magic Wand tools, click Select Subject in the options bar.
. While using the Object  Selection or Quick Selection tools in the Select & Mask workspace, click Select Subject in the options bar.
2. Add to or subtract from the selection
Use any of the Selection tools with their Add to selection and Subtract from selection options to clean up the initial selection, if necessary. See Adjust selections manually.
3. Fine-tune the selection in the Select and Mask workspace
Choose Select > Select and Mask to open the image in the Select and Mask workspace. Use the tools and sliders in the workspace to clean up the selection further. 
See Select and Mask workspace.
You can also make your selection from within the Select & Mask workspace. 

[bookmark: _Toc179963312]How is the Object Selection tool different from the Select Subject command?
The Object Selection tool is useful when you only need to select one of the objects or part of an object within an image that contains multiple objects. While the Select Subject command is designed to select all the main subjects in the image.
To learn more about the Select Subject command, read the next topic described in this article below.

[bookmark: _Toc179963313]Quick Selection tool
You can use the Quick Selection tool [image: ] to quickly "paint" a selection using an adjustable round brush tip. As you drag, the selection expands outward and automatically finds and follows defined edges in the image.
1. Select the Quick Selection tool  [image: ]. (If the tool isn't visible, hold down the Magic Wand tool  [image: ].)
2. In the options bar, click one of the selection options: New, Add To, or Subtract From.
 
New is the default option if nothing is selected. After making the initial selection, the option changes automatically to Add To.
3. To change the brush tip size, click the Brush pop-up menu in the options bar, and type in a pixel size or drag the slider. Use the Size pop‑up menu options to make the brush tip size sensitive to pen pressure or a stylus wheel.
Note: When creating a selection, press the right bracket (]) to increase the Quick Selection tool brush tip size; press the left bracket ([) to decrease the brush tip size.
4. Choose Quick Selection options:
Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer.
Enhance Edge: Reduces roughness and blockiness in the selection boundary. Enhance Edge automatically flows the selection further toward image edges and applies some of the edge refinement you can apply manually in the Select and Mask workspace.
5. Paint inside the part of the image you want to select. The selection grows as you paint. If updating is slow, continue to drag to allow time to complete work on the selection. As you paint near the edges of a shape, the selection area extends to follow the contours of the shape edge.
[image: Photoshop Paint with the Quick Selection tool]
Painting with the Quick Selection tool to extend the selection
. To subtract from a selection, click the Subtract From option in the options bar, then drag over the existing selection.
. To temporarily switch between add and subtract modes, hold down the Alt (Win) or Option (Mac) key. 
. To change the tool cursor, choose Edit > Preferences > Cursors > Painting Cursors (Win) or Photoshop > Preferences > Cursors > Painting Cursors (Mac). Normal Brush Tip displays the standard Quick Selection cursor with a plus or minus sign to show the selection mode.
 
Note: If you stop dragging and then click or drag in a nearby area, the selection will grow to include the new area.
6. Click Select and Mask to further adjust the selection boundary. 

[bookmark: _Toc179963314]Magic Wand tool
The Magic Wand tool lets you select a consistently colored area (for example, a red flower) without having to trace its outline. You specify the selected color range, or tolerance, relative to the original color you click.
Note: You cannot use the Magic Wand tool on an image in Bitmap mode or on 32‑bits-per-channel images.
1. Select the Magic Wand tool  [image: ]. (If the tool isn't visible, access it by holding down the Quick Selection tool  [image: ].)
2. Specify one of the selection options in the options bar. The Magic Wand tool's pointer changes depending on which option is selected.
[image: Photoshop Selection options]
Selection options
A. New B. Add To C. Subtract From D. Intersect With 
3. In the options bar, specify any of the following:
Tolerance: Determines the color range of selected pixels. Enter a value in pixels, ranging from 0 to 255. A low value selects the few colors very similar to the pixel you click. A higher value selects a broader range of colors.
Anti-aliased: Creates a smoother-edged selection.
Contiguous: Selects only adjacent areas using the same colors. Otherwise, all pixels in the entire image using the same colors are selected.
Sample All Layers: Selects colors using data from all the visible layers. Otherwise, the Magic Wand tool selects colors from the active layer only.
4. In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.
5. Click Select and Mask to further adjust the selection boundary or view the selection against different backgrounds or as a mask. 

[bookmark: _Toc179963315]Lasso Tool
Use the Lasso tool  to draw freeform segments of a selection border.
1. Select Lasso tool and and enter a Feather value in the options bar to define the width of the feathering. Notice the Anti-alias box is selected by default.
See Soften the edges of selections to know more about feathering and anti-aliasing. 
2. To add to, subtract from, or intersect with an existing selection, select the correct option in the options bar.
[image: Add to, subtract from or intersect with an existing selection from the options bar]Add to, subtract from or intersect with an existing selection from the options bar

3. Do either of the following:
. Drag to draw a freehand selection border.
. To switch between freehand and straight-edged segments, select Alt (Windows) or Option (macOS), and select where segments should begin and end. To erase recently drawn straight segments, hold down the Delete key.
4. To close the selection border, release the mouse without holding down Alt or Option.
5. (Optional) Select Select and Mask to further adjust the selection boundary. 

[bookmark: _Toc179963316]Polygonal Lasso Tool
Use the Polygonal Lasso tool to draw straight-edged segments of a selection border.
1. Select Polygonal Lasso tool and then the selection options from the options bar.
2. (Optional) Set feathering and anti-aliasing in the options bar. See Soften the edges of selections.
3. Select in the image to set the starting point.
4. Do one or more of the following: 
. To draw a straight segment, select and position the pointer where you want the first straight segment to end. Continue selecting to set endpoints for subsequent segments.
. To draw a straight line at a multiple of 45°, hold down Shift as you move to select the next segment.
. To draw a freehand segment, hold down Alt (Windows) or Option (Mac OS), and drag. When you finish, release Alt or Option and the mouse button.
. To erase recently drawn straight segments, press the Delete key.
5. Close the selection border: 
. Select and position the Polygonal Lasso tool pointer over the starting point (a closed circle appears next to the pointer). 
. If the pointer is not over the starting point, double-click the Polygonal Lasso tool pointer, or Ctrl-click (Windows) or Command-click (Mac OS).
6. (Optional) Select Select and Mask to further adjust the selection boundary.

[bookmark: _Toc179963317]Magnetic Lasso Tool
When you use the Magnetic Lasso tool [image: ], the border snaps to the edges of defined areas in the image. The Magnetic Lasso tool is not available for 32‑bits-per-channel images.
Note: The Magnetic Lasso tool is especially useful for quickly selecting objects with complex edges set against high-contrast backgrounds.
1. Select the Magnetic Lasso tool.
2. Specify one of the selection options in the options bar.
3. (Optional) Set feathering and anti-aliasing in the options bar. See Soften the edges of selections.
4. Set any of these options: 
Width
To specify a detection width, enter a pixel value for Width. The Magnetic Lasso tool detects edges only within the specified distance from the pointer.
 
Note: To change the lasso pointer so that it indicates the lasso width, press the Caps Lock key. You can change the pointer while the tool is selected but not in use. Press the right bracket (]) to increase the Magnetic Lasso edge width by 1 pixel; press the left bracket ([) to decrease the width by 1 pixel.
Contrast
To specify the lasso’s sensitivity to edges in the image, enter a value between 1% and 100% for Contrast. A higher value detects only edges that contrast sharply with their surroundings; a lower value detects lower-contrast edges.
 Frequency
To specify the rate at which the lasso sets fastening points, enter a value between 0 and 100 for Frequency. A higher value anchors the selection border in place more quickly.
 Note: On an image with well-defined edges, try a higher width and higher edge contrast, and trace the border roughly. On an image with softer edges, try a lower width and lower edge contrast, and trace the border more precisely.
 
Stylus Pressure
If you are working with a stylus tablet, select or deselect the Stylus Pressure option. When the option is selected, an increase in stylus pressure decreases the edge width.
5. Select in the image to set the first fastening point. Fastening points anchor the selection border in place.
6. Release the mouse button or keep it pressed, and then move the pointer along the edge you want to trace.
 
The most recent segment of the selection border remains active. As you move the pointer, the active segment snaps to the strongest edge in the image, based on the detection width set in the options bar. Periodically, the Magnetic Lasso tool adds fastening points to the selection border to anchor previous segments.
7. If the border doesn’t snap to the desired edge, select once to add a fastening point manually. Continue to trace the edge, and add fastening points as needed.
[image: Photoshop Fastening points anchor selection border to edges]
Fastening points anchor selection border to edges

8. To switch temporarily to the other lasso tools, do one of the following: 
. To activate the Lasso tool, hold down Alt (Windows) or Option (Mac OS), and drag while pressing the mouse button. 
. Select to activate the Polygonal Lasso tool, hold down Alt (Windows) or Option (Mac OS).
9. To erase recently drawn segments and fastening points, press the Delete key until you’ve erased the fastening points for the desired segment.
10. Close the selection border: 
. To close the border with a magnetic segment, double-click, or press Enter or Return. 
(To manually close the border, select and drag over the starting point.) 
. To close the border with a straight segment, hold down Alt (Windows) or Option (Mac OS), and double-click.
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Launch the Select and Mask workspace
1. Enable a selection tool, such as Object Selection, Quick Selection, Magic Wand, Lasso, or Marquee tools.
2. Now, select Select and Mask in the options bar.
[image: Options bar | Select and Mask button]
User interface
[image: Select and Mask workspace]
Select and Mask workspace

A. Tool options B. Tools C. Adjustable properties 
[bookmark: _Toc179963319]Tools at a glance
The Select and Mask workspace features a combination of familiar and new tools:
Quick Selection Tool: Make quick selections based on color and texture similarity when you select or click-drag the area you want to select. The selection you make doesn’t need to be precise, because the Quick Selection tool ( ) automatically and intuitively creates a border.
For an even easier experience while using the Quick Selection tool, select Select Subject in the options bar to automatically select the most prominent subjects in your image with a single click.
Check out Make quick selections for more information about this tool.
Refine Edge Brush Tool: Precisely adjust the border area in which edge refinement occurs. For example, brush over soft areas such as hair or fur to add fine details to the selection. To change the brush size, press the bracket keys.
Brush Tool: Begin with making a rough selection using the Quick Selection tool (or another selection tool) and then refine it using the Refine Edge Brush tool. Now, use the Brush tool ( ) to finalize or clean up details.
Use the Brush tool to fine-tune selections in two simple ways: paint over the area you want to select in the Add mode, or paint over areas you don’t want to select in the Subtract mode.
Object Selection Tool: Object Selection Tool ( ) uses machine learning to detect, refine, and select objects and regions in an image and create corresponding selections. Hover over the image to see what objects or regions are detected. Select to select a detected object, or use the Rectangle or Lasso, and drag around the object you want to select.
Lasso Tool: Draw freehand selection borders. Using this tool, you can make precise selections.
Check out Select with the Lasso tool to learn more.
Polygonal Lasso Tool: Draw straight-edged segments of a selection border. Using this tool, you can make straight or freehand selections. You can select this tool from the options when you right-click Lasso Tool.
Check out Select with the Polygonal Lasso tool
Hand Tool: Navigate around an image document quickly. Select this tool and drag around the image canvas. You can also quickly toggle the Hand tool by holding spacebar while using any other tool.
Zoom Tool: Magnify and navigate around the photo.
Options bar (Control panel)
[image: Select and Mask workspace: Options bar]
Add or Subtract: Add or subtract from the refinement area. Adjust the brush size if necessary.
Sample All Layers: Creates a selection based on all layers rather than only the currently selected layer
Select Subject: Select the main subjects in a photo in a single click
Refine Hair: Easily find and refine difficult hair selections in a single click. Couple with Object Aware for best results.
Refine the selection
You can refine your selection in the Properties panel of the Select and Mask workspace. To do so, adjust the following settings:
View Mode settings
View Mode: From the View pop-up menu, choose one of the following view modes for your selection:
· Onion Skin (O): Visualizes the selection as an animation-style onion skin against the background. The transparency can be adjusted with the Transparency slider.
· Marching Ants (M): Visualizes the selection borders as marching ants
· Overlay (V): Visualizes the selection as a transparent color overlay. Unselected areas are displayed in that color. The default color is red. 
· On Black (A): Places the selection over a black background
· On White (T): Places the selection over a white background
· Black & White (K): Visualizes the selection as a black and white mask
· On Layers (Y): Surrounds the selection with areas of transparency
Press F to cycle through the modes and X to temporarily disable all modes.
Show Edge (J): Shows the area of refinement.
Show Original (P): Shows the original selection.
High Quality Preview: Renders an accurate preview of the changes. This option may affect performance. When this option is selected, while working on the image, hold down the left mouse button (mouse down) to view a higher-resolution preview. When this option is deselected, a lower-resolution preview is displayed even on mouse down.
Transparency/Opacity: Sets transparency/opacity for the View Mode.
Real-time Refinement: When enabled, affects the preview while brushing using the refine edge tool. When this option is deselected, the brush strokes are displayed even on mouse down, and the results get updated with the refined area on mouse-up.
Refine modes
Set the edge refinement method used by Edge Detection, Refine Hair, and the Refine Edge Brush Tool.
· Color Aware: Choose this mode for simple or contrasting backgrounds.
· Object Aware: Choose this mode for hair or fur on complex backgrounds.

Edge Detection settings
Radius: Determines the size of the selection border in which edge refinement occurs. Use a small radius for sharp edges, and a large one for softer edges.
Smart Radius: Allows for a variable width refinement area around the edge of your selection. Among other use cases, this option is helpful if your selection is a portrait that includes both hair and shoulders. In such portraits, the hair might require a larger refinement area than the shoulders, where the edge is more consistent.
Tip: You can view the radius when the Show Edge checkbox in the View Mode section is enabled. 

Global Refinement settings
Smooth: Reduces irregular areas (“hills and valleys”) in the selection border to create a smoother outline
Feather: Blurs the transition between the selection and the surrounding pixels
Contrast: When increased, soft-edged transitions along the selection border become more abrupt. Typically, the Smart Radius option and refinement tools are more effective.
Shift Edge: Moves soft-edged borders inward with negative values or outward with positive ones. Shifting these borders inward can help remove unwanted background colors from selection edges.

Output Settings
Decontaminate Colors: Replaces color fringes with the color of fully selected pixels nearby. The strength of color replacement is proportionate to the softness of selection edges. Adjust the slider to change the decontamination amount. 100% (maximum strength) is the default value. Because this option changes pixel color, it requires output to a new layer or document. Retain the original layer so you can revert to it if needed.
Output To: Determines whether the refined selection becomes a selection or mask on the current layer, or produces a new layer or document.
[image: output settings]
Output settings

Adjustment and fill layers
An Adjustment Layer applies color and tonal adjustments to your image without permanently changing pixel values. For example, rather than making a Levels or Curves adjustment directly to your image, you can create a Levels or Curves adjustment layer. The color and tonal adjustments are stored in the adjustment layer and apply to all the layers below it; you can correct multiple layers by making a single adjustment, rather than adjusting each layer separately. You can discard your changes and restore the original image at any time.
Fill layers let you fill a layer with a solid color, a gradient, or a pattern. Unlike adjustment layers, fill layers do not affect the layers underneath them.
Adjustment layers provide the following advantages:
Nondestructive edits. You can try different settings and re‑edit the adjustment layer at any time. You can also reduce the effect of the adjustment by lowering the opacity of the layer.
Selective editing. Paint on the adjustment layer's image mask to apply an adjustment to part of an image. Later you can control which parts of the image are adjusted by re-editing the layer mask. You can vary the adjustment by painting on the mask with different tones of gray.
Ability to apply adjustments to multiple images. Copy and paste adjustment layers between images to apply the same color and tonal adjustments.
Adjustment layers have many of the same characteristics as other layers. You can adjust their opacity and blending mode, and you can group them to apply the adjustment to specific layers. Likewise, you can turn their visibility on and off to apply or preview the effect.
Create and confine adjustment and fill layers
Adjustment and fill layers have the same opacity and blending mode options as image layers. You can rearrange, delete, hide, and duplicate them just as you do image layers.
[image: Create an adjustment or fill layer in Photoshop][image: A screenshot of a computer
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Do one of the following:
1. Click the New Adjustment Layer button at the bottom of the Layers panel and choose an adjustment layer type.
2. Choose Layer > New Adjustment Layer and choose an option. Name the layer, set layer options, and click OK.
Fill layers
To create a fill layer, do one of the following:  
Choose Layer > New Fill Layer, and choose an option - Solid Color, Gradient, or Pattern. Name the layer, set layer options, and click OK.
Click the New Adjustment Layer button  at the bottom of the Layers panel, and choose a fill layer type - Solid Color, Gradient, or Pattern.
Solid Color
Fills the adjustment layer with the current foreground color. Use the Color Picker to select a different a fill color.
Gradient
Click the gradient to display the Gradient Editor, or click the inverted arrow and choose a gradient from the pop‑up panel. Set additional options if desired.
· Style specifies the shape of the gradient.
· Angle specifies the angle at which the gradient is applied.
· Scale changes the size of the gradient.
· Reverse flips the orientation of the gradient.
· Dither reduces banding by applying dithering to the gradient.
· Align With Layer uses the bounding box of the layer to calculate the gradient fill. You can drag in the image window to move the center of the gradient.
Pattern

Beginning with Photoshop 21.2, you can also set an angle to rotate the fill layer's pattern and easily change its orientation.
In the Pattern Fill dialog, choose a pattern from the pop‑up menu. Set the following options as required: 
· Angle specifies the angle at which the pattern is applied. Set the angle selector at a certain degree or manually type in an angle value to rotate your pattern at the desired angle.
· Scale changes the size of the pattern. Enter a value or drag the slider.
· Link With Layer moves the pattern along with the layer as the layer moves. When selected, you can drag in the image to position the pattern while the Pattern Fill dialog box is open.
· Snap To Origin makes the origin of the pattern the same as the origin of the document.

Adjustment layers
Brightness/Contrast 
The Brightness/Contrast adjustment lets you make simple adjustments to the tonal range of an image. Moving the brightness slider to the right increases tonal values and expands image highlights, to the left decreases values and expands shadows. The contrast slider expands or shrinks the overall range of tonal values in the image.
In normal mode, Brightness/Contrast applies proportionate (nonlinear) adjustments to the image layer, as with Levels and Curves adjustments. When Use Legacy is selected, Brightness/Contrast simply shifts all pixel values higher or lower when adjusting brightness. Since this can cause clipping or loss of image detail in highlight or shadow areas, using Brightness/Contrast in Legacy mode is not recommended for photographic images (but can be useful for editing masks or scientific imagery).
Note: Use Legacy is automatically selected when editing Brightness/Contrast adjustment layers created with previous versions of Photoshop.
Do one of the following: 
· Click the Brightness/Contrast icon  in the Adjustments panel.
· Choose Layer > New Adjustment Layer > Brightness/Contrast. Click OK in the New Layer dialog box. 
In the Properties panel, drag the sliders to adjust the brightness and contrast. 
Dragging to the left decreases the level and dragging to the right increases it. The number at the right of each slider reflects the brightness or contrast value. Values can range from ‑150 to +150 for Brightness, ‑50 to +100 for Contrast.
Adjust tonal range using Levels
The outer two Input Levels sliders map the black point and white point to the settings of the Output sliders. By default, the Output sliders are at level 0, where the pixels are black, and level 255, where the pixels are white. With the Output sliders in the default positions, moving the black input slider maps the pixel value to level 0 and moving the white point slider maps the pixel value to level 255. The remaining levels are redistributed between levels 0 and 255. This redistribution increases the tonal range of the image, in effect increasing the overall contrast of the image.
Note: When shadows are clipped, the pixels are black, with no detail. When highlights are clipped, the pixels are white, with no detail.
The middle Input slider adjusts the gamma in the image. It moves the midtone (level 128) and changes the intensity values of the middle range of gray tones without dramatically altering the highlights and shadows.
1. Do one of the following:
· Click the Levels icon [image: ] in the Adjustments panel, or choose Levels from the panel menu.
· Choose Layer > New Adjustment Layer > Levels. Click OK in the New Layer dialog box.
Note: Choosing Image > Adjustments > Levels makes direct adjustments to the image layer and discards image information.
2. (Optional) To adjust tones for a specific color channel, choose an option from the Channel menu.
3. (Optional) To edit a combination of color channels at the same time, Shift-select the channels in the Channels panel before choosing the Image > Adjustments > Levels command. (This method does not work in a Levels adjustment layer.) The Channel menu then displays the abbreviations for the target channels—for example, CM for cyan and magenta. The menu also contains the individual channels for the selected combination. Edit spot channels and alpha channels individually.
4. To adjust the shadows and highlights manually, drag the black and white Input Levels sliders to the edge of the first group of pixels at either end of the histogram.
 
For example, if you move the black point slider to the right at level 5, Photoshop maps all the pixels at level 5 and lower to level 0. Similarly, if you move the white point slider to the left at level 243, Photoshop maps all pixels at level 243 and higher to level 255. The mapping affects the darkest and lightest pixels in each channel. The corresponding pixels in the other channels are adjusted proportionately to avoid altering the color balance.
 
Note: 
You can also enter values directly into the first and third Input Levels text boxes.
[image: Photoshop Adjusting black and white points]
Adjusting black and white points with Levels Input sliders
5. (Optional) To identify areas in the image that are being clipped (completely black or completely white), do one of the following:
· Hold down Alt (Windows) or Option (Mac OS) as you drag the black point and white point sliders.
· Choose Show Clipping For Black/White Points from the panel menu.
6. To adjust midtones, use the middle Input slider to make a gamma adjustment.
Moving the middle Input slider to the left makes the overall image lighter. This slider adjustment maps a lower (darker) level up to the midpoint level between the Output sliders. If the Output sliders are in their default position (0 and 255), the midpoint is level 128. In this example, the shadows expand to fill the tonal range from 0 to 128, and the highlights are compressed. Moving the middle Input slider to the right has the opposite effect, making the image darker.
 
Note: You can also enter a gamma adjustment value directly in the middle Input Levels box.
You can view the adjusted histogram in the Histogram panel.
Adjust color using Levels
1. In the Adjustments panel, click the Levels icon [image: ] or choose Levels from the panel menu.
2. In the Properties panel, do one of the following to neutralize a color cast:
· Click the eyedropper tool to set the gray point [image: ]. Then click in a part of the image that is neutral gray.
· Click Auto to apply the default automatic levels adjustment. To experiment with other automatic adjustment options, choose Auto Options from the Properties panel menu, then change Algorithms in the Auto Color Corrections Options dialog box.
 
In general, assign equal color component values to achieve a neutral gray. For example, assign equal red, green, and blue values to produce a neutral gray in an RGB image.
Add contrast to a photo with Levels
If the image needs overall contrast because it doesn’t use the full tonal range, click the Levels icon [image: ] in the Adjustments panel. Then drag the Shadow and Highlight input sliders inward until they touch the ends of the histogram.
[image: Photoshop Contrast levels]
Image layer doesn’t extend to the ends of the graph, indicating that the image is not using the full tonal range.
A. Shadow Input slider B. Highlight Input slider 




Blending modes 
Choose from the Mode pop‑up menu in the options bar.
Note: In the Blend Mode pop-up menu, scroll over different options to see how they look on your image. Photoshop displays a live preview of blend modes on the canvas.
Only the Normal, Dissolve, Darken, Multiply, Lighten, Linear Dodge (Add), Difference, Hue, Saturation, Color, Luminosity, Lighter Color, and Darker Color blending modes are available for 32‑bit images.
Normal: Edits or paints each pixel to make it the result color. This is the default mode. (Normal mode is called Threshold when you’re working with a bitmapped or indexed-color image.)
Dissolve: Edits or paints each pixel to make it the result color. However, the result color is a random replacement of the pixels with the base color or the blend color, depending on the opacity at any pixel location.
Behind: Edits or paints only on the transparent part of a layer. This mode works only in layers with Lock Transparency deselected and is analogous to painting on the back of transparent areas on a sheet of acetate.
Clear: Edits or paints each pixel and makes it transparent. This mode is available for the Shape tools (when fill region  is selected), Paint Bucket tool , Brush tool , Pencil tool , Fill command, and Stroke command. You must be in a layer with Lock Transparency deselected to use this mode.
Darken: Looks at the color information in each channel and selects the base or blend color—whichever is darker—as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change.
Multiply: Looks at the color information in each channel and multiplies the base color by the blend color. The result color is always a darker color. Multiplying any color with black produces black. Multiplying any color with white leaves the color unchanged. When you’re painting with a color other than black or white, successive strokes with a painting tool produce progressively darker colors. The effect is similar to drawing on the image with multiple marking pens.
Color Burn: Looks at the color information in each channel and darkens the base color to reflect the blend color by increasing the contrast between the two. Blending with white produces no change.
Linear Burn: Looks at the color information in each channel and darkens the base color to reflect the blend color by decreasing the brightness. Blending with white produces no change.
Lighten: Looks at the color information in each channel and selects the base or blend color—whichever is lighter—as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change.
Screen: Looks at each channel’s color information and multiplies the inverse of the blend and base colors. The result color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white. The effect is similar to projecting multiple photographic slides on top of each other.
Color Dodge: Looks at the color information in each channel and brightens the base color to reflect the blend color by decreasing contrast between the two. Blending with black produces no change.
Linear Dodge (Add): Looks at the color information in each channel and brightens the base color to reflect the blend color by increasing the brightness. Blending with black produces no change.
Overlay: Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing pixels while preserving the highlights and shadows of the base color. The base color is not replaced, but mixed with the blend color to reflect the lightness or darkness of the original color.

Soft Light: Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the image. If the blend color (light source) is lighter than 50% gray, the image is lightened as if it were dodged. If the blend color is darker than 50% gray, the image is darkened as if it were burned in. Painting with pure black or white produces a distinctly darker or lighter area, but does not result in pure black or white.
Hard Light: Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the image. If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were screened. This is useful for adding highlights to an image. If the blend color is darker than 50% gray, the image is darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting with pure black or white results in pure black or white.
Vivid Light: Burns or dodges the colors by increasing or decreasing the contrast, depending on the blend color. If the blend color (light source) is lighter than 50% gray, the image is lightened by decreasing the contrast. If the blend color is darker than 50% gray, the image is darkened by increasing the contrast.
Linear Light: Burns or dodges the colors by decreasing or increasing the brightness, depending on the blend color. If the blend color (light source) is lighter than 50% gray, the image is lightened by increasing the brightness. If the blend color is darker than 50% gray, the image is darkened by decreasing the brightness.
Pin Light: Replaces the colors, depending on the blend color. If the blend color (light source) is lighter than 50% gray, pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change. If the blend color is darker than 50% gray, pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change. This is useful for adding special effects to an image.
Hard Mix: Adds the red, green and blue channel values of the blend color to the RGB values of the base color. If the resulting sum for a channel is 255 or greater, it receives a value of 255; if less than 255, a value of 0. Therefore, all blended pixels have red, green, and blue channel values of either 0 or 255. This changes all pixels to primary additive colors (red, green, or blue), white, or black.
*Note: For CMYK images, Hard Mix changes all pixels to the primary subtractive colors (cyan, yellow, or magenta), white, or black. The maximum color value is 100.
Difference: Looks at the color information in each channel and subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value. Blending with white inverts the base color values; blending with black produces no change.
Exclusion: Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts the base color values. Blending with black produces no change.
Subtract: Looks at the color information in each channel and subtracts the blend color from the base color. In 8- and 16-bit images, any resulting negative values are clipped to zero.
Divide: Looks at the color information in each channel and divides the blend color from the base color.
Hue: Creates a result color with the luminance and saturation of the base color and the hue of the blend color.
Saturation: Creates a result color with the luminance and hue of the base color and the saturation of the blend color. Painting with this mode in an area with no (0) saturation (gray) causes no change.
Color: Creates a result color with the luminance of the base color and the hue and saturation of the blend color. This preserves the gray levels in the image and is useful for coloring monochrome images and for tinting color images.
Luminosity: Creates a result color with the hue and saturation of the base color and the luminance of the blend color. This mode creates the inverse effect of Color mode.

Lighter Color: Compares the total of all channel values for the blend and base color and displays the higher value color. Lighter Color does not produce a third color, which can result from the Lighten blend, because it chooses the highest channel values from both the base and blend color to create the result color.
[image: A collage of different images of a penguin mask

Description automatically generated][image: A collage of different images of a person wearing a mask

Description automatically generated]Darker Color: Compares the total of all channel values for the blend and base color and displays the lower value color. Darker Color does not produce a third color, which can result from the Darken blend, because it chooses the lowest channel values from both the base and the blend color to create the result color.

[image: A collage of different colored masks

Description automatically generated]
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